From 926900dd0841c8a233fec53c9fb844a813a6befc Mon Sep 17 00:00:00 2001 From: "dependabot[bot]" <49699333+dependabot[bot]@users.noreply.github.com> Date: Thu, 22 Oct 2026 11:22:32 +0000 Subject: [PATCH 1/5] Update nornir requirement from >=3.5.0 to >=3.6.0 Updates the requirements on [nornir](https://github.com/nornir-automation/nornir) to permit the latest version. - [Release notes](https://github.com/nornir-automation/nornir/releases) - [Changelog](https://github.com/nornir-automation/nornir/blob/main/CHANGELOG.rst) - [Commits](https://github.com/nornir-automation/nornir/compare/v3.5.0...v3.6.0) --- updated-dependencies: - dependency-name: nornir dependency-version: 3.6.0 dependency-type: direct:production ... Signed-off-by: dependabot[bot] --- ai-requirements.txt | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/ai-requirements.txt b/ai-requirements.txt index 6125ed124..f9a434708 100644 --- a/ai-requirements.txt +++ b/ai-requirements.txt @@ -32,7 +32,7 @@ langsmith>=0.14.7 # Network Automation paramiko>=5.0.0 # install version >= 5.0.0 to address CVE-2026-44405 netmiko>=4.8.0 -nornir>=3.5.0 +nornir>=3.6.0 nornir-netmiko>=1.0.1 nornir-utils>=0.3.0 nornir-salt>=0.23.4 From 176fc4bb5d11c25315a0ca6461379c2008a2b4a9 Mon Sep 17 00:00:00 2001 From: "dependabot[bot]" <49699333+dependabot[bot]@users.noreply.github.com> Date: Thu, 22 Oct 2026 11:22:37 +0000 Subject: [PATCH 2/5] Bump rust-just from 1.58.0 to 1.59.0 Bumps [rust-just](https://github.com/gnpaone/rust-just) from 1.58.0 to 1.59.0. - [Release notes](https://github.com/gnpaone/rust-just/releases) - [Changelog](https://github.com/gnpaone/rust-just/blob/master/CHANGELOG.md) - [Commits](https://github.com/gnpaone/rust-just/compare/1.58.0...1.59.0) --- updated-dependencies: - dependency-name: rust-just dependency-version: 1.59.0 dependency-type: direct:development update-type: version-update:semver-minor ... Signed-off-by: dependabot[bot] --- dev-requirements.txt | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/dev-requirements.txt b/dev-requirements.txt index 03642922f..264ac5977 100644 --- a/dev-requirements.txt +++ b/dev-requirements.txt @@ -7,4 +7,4 @@ pytest-random-order==1.2.0 # opt-in: --random-order --random-order-bucket=globa pytest-cov==7.1.0 ruff==0.16.9 mypy==2.4.0 -rust-just==1.58.0 # provides the `just` command runner, see justfile +rust-just==1.59.0 # provides the `just` command runner, see justfile From 3d304a01ea76ab0c99d972290431fefa80e039dc Mon Sep 17 00:00:00 2001 From: "dependabot[bot]" <49699333+dependabot[bot]@users.noreply.github.com> Date: Thu, 22 Oct 2026 11:22:47 +0000 Subject: [PATCH 3/5] Update langchain-ollama requirement from >=1.0.1 to >=1.1.0 Updates the requirements on [langchain-ollama](https://github.com/langchain-ai/langchain) to permit the latest version. - [Release notes](https://github.com/langchain-ai/langchain/releases) - [Commits](https://github.com/langchain-ai/langchain/compare/langchain-ollama==1.0.1...langchain-ollama==1.1.0) --- updated-dependencies: - dependency-name: langchain-ollama dependency-version: 1.1.0 dependency-type: direct:production ... Signed-off-by: dependabot[bot] --- ai-requirements.txt | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/ai-requirements.txt b/ai-requirements.txt index 6125ed124..6627eb032 100644 --- a/ai-requirements.txt +++ b/ai-requirements.txt @@ -19,7 +19,7 @@ langchain-openai>=1.1.10 langchain-anthropic>=1.3.4 langchain-google-genai>=4.2.1 langchain-aws>=1.8.1 -langchain-ollama>=1.0.1 +langchain-ollama>=1.1.0 langchain-deepseek>=1.0.1 langchain-xai>=1.2.2 From 9549425924a3ec1c666c5795746a6aa6d30e5695 Mon Sep 17 00:00:00 2001 From: "dependabot[bot]" <49699333+dependabot[bot]@users.noreply.github.com> Date: Thu, 22 Oct 2026 11:22:58 +0000 Subject: [PATCH 4/5] Update sentry-sdk requirement from <3,>=2.70.0 to >=2.72.0,<3 Updates the requirements on [sentry-sdk](https://github.com/getsentry/sentry-python) to permit the latest version. - [Release notes](https://github.com/getsentry/sentry-python/releases) - [Changelog](https://github.com/getsentry/sentry-python/blob/master/CHANGELOG.md) - [Commits](https://github.com/getsentry/sentry-python/compare/2.70.0...2.72.0) --- updated-dependencies: - dependency-name: sentry-sdk dependency-version: 2.72.0 dependency-type: direct:production ... Signed-off-by: dependabot[bot] --- requirements.txt | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/requirements.txt b/requirements.txt index c874bfbb4..13c6a6002 100644 --- a/requirements.txt +++ b/requirements.txt @@ -7,7 +7,7 @@ websockets==16.1.1 # google-genai 2.10.0 has requirement websockets<17.0 aiohttp>=3.14.4,<3.15 aiofiles>=25.1.0,<26.0 Jinja2>=3.1.6,<3.2 -sentry-sdk>=2.70.0,<3 # optional dependency +sentry-sdk>=2.72.0,<3 # optional dependency psutil>=7.2.2 distro>=1.9.0 py-cpuinfo>=9.0.0,<10.0 From fdf6e3655598c68a06a12552d351b229dfcb051b Mon Sep 17 00:00:00 2001 From: "dependabot[bot]" <49699333+dependabot[bot]@users.noreply.github.com> Date: Thu, 22 Oct 2026 16:26:05 +0000 Subject: [PATCH 5/5] Update langchain-aws requirement from >=1.8.1 to >=1.9.0 Updates the requirements on [langchain-aws](https://github.com/langchain-ai/langchain-aws) to permit the latest version. - [Release notes](https://github.com/langchain-ai/langchain-aws/releases) - [Commits](https://github.com/langchain-ai/langchain-aws/compare/langchain-aws==1.8.1...langchain-aws==1.9.0) --- updated-dependencies: - dependency-name: langchain-aws dependency-version: 1.9.0 dependency-type: direct:production ... Signed-off-by: dependabot[bot] --- ai-requirements.txt | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/ai-requirements.txt b/ai-requirements.txt index 34861b7fe..64b23ef7f 100644 --- a/ai-requirements.txt +++ b/ai-requirements.txt @@ -18,7 +18,7 @@ langgraph-checkpoint-postgres>=3.0.4 langchain-openai>=1.1.10 langchain-anthropic>=1.3.4 langchain-google-genai>=4.2.1 -langchain-aws>=1.8.1 +langchain-aws>=1.9.0 langchain-ollama>=1.1.0 langchain-deepseek>=1.0.1 langchain-xai>=1.2.2